Bryston 4b Help Left channel light stays red on start up
Welcome to the AudioShark Forums.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Sep 2019
    Location
    usa
    Posts
    2
    Post Thanks / Like

    Bryston 4b Help Left channel light stays red on start up

    Hi,
    I have an old 4b that i'm trying to get working again. The power switch on the front went bad so I ordered a new soft start board with the switch and soldered it in. The switch is working but now on the Left the led stays red - Any ideas of where to start troubleshooting? I haven't hooked up any source or speakers to see if it passes audio.
    Many thanks,
    J

  2. #2
    Super Moderator
    Join Date
    Apr 2013
    Location
    NY
    Posts
    16,420
    Post Thanks / Like

    Re: Bryston 4b Help Left channel light stays red on start up

    Welcome to the forum.
    Joe

    Avantgarde Duo XD, Klipsch RB-75, Klipsch RP-160M, JBL 590.

    Accuphase E-650 w/ Dac, Job INTegrated, Naim Supernait 2 w/ HiCap-DR.

    Conrad Johnson GAT2, Wyred 4 Sound STP-SE Stage 2, Misho Myronov Wooden pre, Linear Tube Audio MZ2.

    First Watt SIT-1 monos, Misho Myronov Wooden amp, First Watt SIT-3, Luxman MQ-300, Job 250 Monos, Valvet E2se, NuForce STA200, AkitikA GT-102 amp, Cary 300B SE monos, ASL Wave monos, Dennis Had 45 monos.

    Lumin U1 mini, ModWright Ultimate Sony XA-5400ES, Audio Mirror Tubadour III NOS R2R Tube Dac w/ upgrades.

    Burmester 948, McIntosh MCLK12, Kimber Kable, Siltech, Cardas, Avanti Audio cables.

  3. #3
    Junior Member
    Join Date
    Sep 2019
    Location
    usa
    Posts
    2
    Post Thanks / Like

    Re: Bryston 4b Help Left channel light stays red on start up

    Quote Originally Posted by joeinid View Post
    Welcome to the forum.
    Thanks Joe - any ideas on getting this fine amp in service again!

  4. #4
    Senior Member
    Join Date
    Apr 2017
    Location
    Central FL
    Posts
    404
    Post Thanks / Like

    Re: Bryston 4b Help Left channel light stays red on start up

    Welcome! Staying red I'd guess is saying it remains muted after start-up. Call Bryston service in Vermont - (802) 334-1201
    Main System - Lumin U1, Modwright LS36.5 DM Preamp, EVS 1200 Amp, EMM Labs DAC 2X (ver. 2), Torus RM-20, Thiel CS 3.7s, 2 Rel Storm III subs
    Back-up 1 - Hegel H190 Integrated Amp/DAC, Integra DPS 6.9 Transport, 2 Richard Gray cond, Ohm Microwalsh Talls, Rel Strata III sub
    Back-up 2 - Sherbourn Pre-1, Mivera PurePowerSE Amp, Oppo UDP-203, Vansevers cond, B&W P6s, Sumiko S.5 sub

  5. #5
    Senior Member
    Join Date
    Sep 2017
    Location
    Minneapolis, MN
    Posts
    537
    Post Thanks / Like

    Re: Bryston 4b Help Left channel light stays red on start up

    Bryston support is the best in the business. They’ll take care of you.


    Sent from my iPhone using Tapatalk
    Processor: Bryston SP3
    Amps: Bryston 28b3s, Bryston 4b3, Bryston 9bsst2
    Digital: EMM NS1, EMM DA2
    Speakers: Kef Reference 5, Kef Reference 4c, Kef Ci200RR-THX (surround/back)
    Subs: Two JL Audio F212v2
    Power: PS Audio PS10, Bryston BIT15
    Wires: Wireworld Silver Eclipse XLR & SC, Ethernet - WW Platinum USB
    Other: Stillpoint Ultra SS, ISO-Acoustics ISO Pucks
    Video: Oppo 203, LG 65inch OLED
    -Kyle