I'm bumming
Welcome to the AudioShark Forums.
Results 1 to 7 of 7

Thread: I'm bumming

  1. #1
    Senior Member
    Join Date
    Nov 2013
    Location
    St. Louis, MO, USA
    Posts
    821
    Post Thanks / Like

    I'm bumming

    My 532h began not powering up. The issue was intermittent at first. Then I couldn't get it to come on at all. I tried other outlets, switched the power cord nothing. At this point I feel it's ready for the shop. The amp is only 18 months old. I contact Harmon on how to proceed and if knew what could be wrong. They eventually sent me a form to fill out with the warranty repair shops addresses etc. but in the email the guy tells me to try the factory reset first to see if it cures the issue. Come to find out this also wipes out the performance history. Why Harmon would tell me to do this is beyond me. So now it is at the shop and supposedly working fine. So no history for them to go on they have to wait until the amp acts up, which I would have thought should have happened already the way it was acting for me. So I could be without my system for a long time.

    I love the sound of the 532h, my system has great synergy to my taste. Now I'm wondering if it's time to move on to something else. This is the sound I like so there's the thought, what if I don't find something I like as much. On the other hand this is the first "high end" amp I had go bad on me. Then to have the company advise me to do something foolish, I'm not happy with them.

    So am I over reacting, and this type of situation is par for the course? I've had perfect performance from Krell, same CJ amps for years with out a hitch, the prior Pass was in the same outlet etc. for a couple years. Unfortunately, my budget isn't large so I have to sell to get something else, what I'd do for one of those old amps to be here now.
    Mark Levinson #512 & 532h, Pass Labs XP10, Hegel HD30, JBL 4367's
    Coda CSX. Clearaudio Performance DC w/Maestro, AcousTech PH-1P
    All Clarus Crimson cabling, AC to binding post. Surgex
    HT: Marantz AV8003, Linn 5125, JBL SAM3ha, Revel s30,
    SVS PC13 Ultra
    Transparent & Tributaries. PS Audio filtering
    Sony XBR-75X940D & BDP

  2. #2
    Senior Member
    Join Date
    May 2013
    Location
    Silicon Valley
    Posts
    1,954
    Post Thanks / Like

    Re: I'm bumming

    Sorry to hear that. Sometimes things just break. Nothing we can do about that. What I have done is build my HT with stereo system hand-me-downs, so I will always have one operational stereo if something should break.

    Stay positive. Things will soon be back to normal.
    Bud

    Lumin S1
    Sony XA-5400ES SACD
    Pass XP-22 pre, X600.5 amps
    Magico S5 MKII Mcast Rose speakers, SPOD spikes

    Shunyata Triton v3/Typhon QR source, Denali 2000 (2) for amps
    Shunyata Sigma XLR analog ICs, Sigma speaker cables
    Shunyata Sigma HC (2), Sigma Analog, Sigma Digital, Z Anaconda (3) power cables

    Mapleshade Samson V.3 four shelf solid maple rack, Micropoint brass footers
    Three 20 amp circuits.

  3. Thanks Mr Peabody thanked for this post
    Likes joeinid, kzhtoo liked this post
  4. #3
    Super Moderator
    Join Date
    Apr 2013
    Location
    NY
    Posts
    15,286
    Post Thanks / Like

    Re: I'm bumming

    Great post Bud. Thank you.
    Joe

    Avantgarde Duo XD, JBL L100 (orange), Luxman MQ-300, JBL 4312SE 70th Anniversary,
    Pass XA25, McIntosh MCLK12, Job INTegrated, Cary 300B SE, JBL 4367, Revel Studio 2, JBL 4312D, Klipsch RP-160M, Klipsch RB-75, ModWright Ultimate Sony XA-5400ES, ASL Wave monos, Kimber Kables, Siltech, Cardas, Avanti Audio cables, Burmester 948, Linear Tube Audio MZ2, Bricasti M1SE, Naim Supernait 2, Lumin U1 mini, Wyred 4 Sound STP-SE Stage 2.

  5. Thanks BlueFox thanked for this post
  6. #4
    Member
    Join Date
    Mar 2017
    Location
    chicago burbs
    Posts
    44
    Post Thanks / Like

    Re: I'm bumming

    The other possibility is the factory reset worked and your amp is functional now?
    Revel salon2's black, Vienna Acoustics Strauss, VA Beethivens, Kef R107/2, Hegel h360, rega jupiter, roon nucleus, revox tuner.

  7. #5
    Senior Member
    Join Date
    Dec 2013
    Posts
    3,274
    Post Thanks / Like

    Re: I'm bumming

    Quote Originally Posted by Mr Peabody View Post
    My 532h began not powering up. The issue was intermittent at first. Then I couldn't get it to come on at all. I tried other outlets, switched the power cord nothing. At this point I feel it's ready for the shop. The amp is only 18 months old. I contact Harmon on how to proceed and if knew what could be wrong. They eventually sent me a form to fill out with the warranty repair shops addresses etc. but in the email the guy tells me to try the factory reset first to see if it cures the issue. Come to find out this also wipes out the performance history. Why Harmon would tell me to do this is beyond me. So now it is at the shop and supposedly working fine. So no history for them to go on they have to wait until the amp acts up, which I would have thought should have happened already the way it was acting for me. So I could be without my system for a long time.

    I love the sound of the 532h, my system has great synergy to my taste. Now I'm wondering if it's time to move on to something else. This is the sound I like so there's the thought, what if I don't find something I like as much. On the other hand this is the first "high end" amp I had go bad on me. Then to have the company advise me to do something foolish, I'm not happy with them.

    So am I over reacting, and this type of situation is par for the course? I've had perfect performance from Krell, same CJ amps for years with out a hitch, the prior Pass was in the same outlet etc. for a couple years. Unfortunately, my budget isn't large so I have to sell to get something else, what I'd do for one of those old amps to be here now.
    Yes. Things happen. You love the sound of this amp in your system. It's fixed and coming back to you. Hook it up and enjoy your system again. If it happens again in the near term, then you can be rightfully pissed and sell it and move on.
    Technics SP-10MKII table in custom plinth with custom power supply made by Peter Noerbaek of PBN, SME 312s arm, Dynavector XV-1s cartridge, Zesto Andros 1.2 phono stage, Otari MX-55 2 track R2R, Ampex 350 tape repros, laptop music server running JRiver 20, Mytek Stereo 192 DAC, ARC Ref 6, ARC Ref 75 with KT-150s, NOLA KO speakers, Viero Equilibro Level 3 speaker cables, and a pair of Definitive Technology Ref subs.

  8. Likes puroagave liked this post
  9. #6
    Member
    Join Date
    Mar 2017
    Location
    chicago burbs
    Posts
    44
    Post Thanks / Like

    Re: I'm bumming

    I bought a krell demo and it 'fixed my speakers' who knew? that amp failed 3 times under warranty and then again shortly after the warranty expired! I have a B&K 4420 the same thing happened, but has worked without issue serving ht duties for the last 10-15 years. I appreciate the satisfaction when you finally get your system to sing and the frustration of having to wait for service. I'm more than a little confident heat was the cause of all my amp failures tho' I was never told so. My current unit has built in thermal protection that I found by activating it! I'm trying to save $$$ to buy a 2nd amp to bi-amp my speakers in hope of lessening the load presented to it, alternatively or intermediately i'm considering a small computer type fan I can run off batteries to keep the internal heat sinks cool. In fact all 3 high powered amps I had trouble with had internal heat sinks while the 1, a parasound a21 with external heatsinks never gave me trouble... Good luck with your 532H.
    Revel salon2's black, Vienna Acoustics Strauss, VA Beethivens, Kef R107/2, Hegel h360, rega jupiter, roon nucleus, revox tuner.

  10. #7
    Senior Member
    Join Date
    Nov 2013
    Location
    St. Louis, MO, USA
    Posts
    821
    Post Thanks / Like

    Re: I'm bumming

    Sorry for not ever coming back. I did get the 532h back and it has been working well. The story I got it was working but they would replace the control board just in case. I think these places are told to keep the customer in the dark. I know for a fact certain amps from Harmon have had issues yet you can't find anything about it on the internet.

    I would not recommend the Harmon repair shop in Austin I used. My amp came back with a piece of wire in one of the speaker terminals like they just yanked it and the wire broke and they did not pack the amp well on the return trip, completely left the plastic wrap off the amp..

    The 532h is in my 2nd system right now. This Coda seems to sound better with using the Hegel DAC.
    Mark Levinson #512 & 532h, Pass Labs XP10, Hegel HD30, JBL 4367's
    Coda CSX. Clearaudio Performance DC w/Maestro, AcousTech PH-1P
    All Clarus Crimson cabling, AC to binding post. Surgex
    HT: Marantz AV8003, Linn 5125, JBL SAM3ha, Revel s30,
    SVS PC13 Ultra
    Transparent & Tributaries. PS Audio filtering
    Sony XBR-75X940D & BDP